The example even used unwrap_or_else where they should use unwrap_or. Then it uses std::i64::MIN as fallback value where they could use something like 0 that would be a better example and honestly make more sense there.
let parsed_numbers = ["1", "not a number", "3"]
.iter()
.map(|n| n.parse().unwrap_or(0))
.collect();
// prints "[1, 0, 3]"println!("{:?}", parsed_numbers);
Even without trimming this to something less convoluted, the same functionality (with different fallback value) could be written in more readable form.
Obviously in the context of the page something like this would make way more sense:
The example even used unwrap_or_else where they should use unwrap_or. Then it uses
std::i64::MIN
as fallback value where they could use something like0
that would be a better example and honestly make more sense there.let parsed_numbers = ["1", "not a number", "3"] .iter() .map(|n| n.parse().unwrap_or(0)) .collect(); // prints "[1, 0, 3]" println!("{:?}", parsed_numbers);
Even without trimming this to something less convoluted, the same functionality (with different fallback value) could be written in more readable form.
Obviously in the context of the page something like this would make way more sense:
maybe_number.unwrap_or(0)
Or perhaps more idiomatic version of the above:
maybe_number.unwrap_or_default()
I think you could even get rid of the
iter()
and thecollect()
since it’s a small fixed size array.